Sign in

Google cloud as server: only index file uploaded

  • This topic has 8 replies, 2 voices, and was last updated 5 months ago by .
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1068
    chrislaux

    Dear Forum users,

    I am new to Publii and set up a Google cloud storage bucket as server, which worked ok. But after synching the website, only a single file is placed into the bucket: “files.publii.json” which appears to be some kind of index file. Of course visiting the website does not work.

    This seems to be a bug with Publii (version v.0.35.3 (build 12104) Beta)?

    Any ideas?

    -Chris

     

    #1079
    Tomasz DziudaTomasz Dziuda
    Moderator

    Hi,

    I am not sure, but it can be related to your bucket configuration. Did you followed our tutorial: https://getpublii.com/docs/make-static-website-google-cloud.html or did you make some custom configuration?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #1082
    chrislaux

    Hi,

    I pretty much followed the tutorial, just that I used a Multi-Regional bucket. But that can’t be the problem. To me it looks like a bug in the software.

    #1083
    Tomasz DziudaTomasz Dziuda
    Moderator

    Could you go to Tools -> Log viewer and check connection-* files?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #1084
    chrislaux

    Ok, I found these two errors below, other such files are empty.

    Is this it? Object policies are disabled? I can’t really find the relevant part of the tutorial to set those… but then the current version of the Google cloud is a bit newer than the tutorial.

    [{“path”:”feed.xml”,”type”:”file”}]

    Founded 2 operations to do
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – -ERROR UPLOAD FILE – – –
    feed.xml
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – – – – – – – – – – – – –
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – -ERROR UPLOAD FILE – – –
    feed.xml
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – – – – – – – – – – – – –
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – -ERROR UPLOAD FILE – – –
    feed.xml
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – – – – – – – – – – – – –
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – -ERROR UPLOAD FILE – – –
    feed.xml
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – – – – – – – – – – – – –
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – -ERROR UPLOAD FILE – – –
    feed.xml
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – – – – – – – – – – – – –
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – -ERROR UPLOAD FILE – – –
    feed.xml
    ApiError: Cannot use ACL API to set object policy when object policies are disabled.
    – – – – – – – – – – – – – –
    UPL HARD ERR …/Publii/sites/…/output/feed.xml -> feed.xml
    -> files.publii.json

    #1085
    chrislaux

    Ok, after changing the bucket to “fine-grained” permissions, I am one step further, it uploads something now.

    But now the CSS assets are missing, with very visible effects…

    Thanks for the help so far, btw.

    #1086
    Tomasz DziudaTomasz Dziuda
    Moderator

    Please check if the CSS files are on your bucket. If yes, then I suppose that your domain is wrongly configured under server settings.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #1087
    chrislaux

    No, the ‘assets’ folder is missing entirely. I have ‘authors’ and ‘amp’ though.

     

    #1088
    chrislaux

    Ok, deleting everything and re-synching did the trick. Seems to be complete now. Thanks. Case closed.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The topic ‘Google cloud as server: only index file uploaded’ is closed to new replies.