Sign in

SFTP Stuck

  • This topic has 10 replies, 3 voices, and was last updated 3 weeks ago by .
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #478
    nilsvb

    Hi, I synced my website to my hosting company (FastComet) successfully via FTP but via SFTP it get stuck (see print screen)
    By the way the Test connection button is OK with SFTP
    Any idea?
    Thank you

    Attachments:
    #484
    Tomasz DziudaTomasz Dziuda
    Moderator

    Hi,

    Please check your logs under Tools -> Log viewer, maybe there is some useful information about your issue.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #501
    nilsvb

    Thanks Tomasz, which one can I send you?

    Attachments:
    #503
    Tomasz DziudaTomasz Dziuda
    Moderator

    Please attach first 8 ones and the last one.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #516
    nilsvb
    #520
    Tomasz DziudaTomasz Dziuda
    Moderator

    Could you check if your SFTP account has proper permissions to access your files on the server?

    Could you also check if the path provided in your server settings is ok?

    I suppose that it must be permission or path issue as Publii cannot find the files.remote.json file during SFTP session.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #532
    nilsvb

    I tested the connection and the connection is working fine

    Also I received this reply from FastComet hosting

    Upon investigating the matter, it appears that your IP XXXXXXXXXXX is not blocked on any of our firewalls.

    We tried to access on our end and we were successful:

    fastcomet5@fastcomet5-desktop:~$ ssh -pXXXXX XXXXXXXXXXXXXXXXXX
    XXXXXXXXXXXXXXXX’s password:
    [XXXXXXXXXXX ~]$

    Any extra idea?

    Thanks

    Attachments:
    #534
    Tomasz DziudaTomasz Dziuda
    Moderator

    Please set option “Remote path” to an absolute path on your server e.g. /var/www/domain.com/public_html/

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #535
    Tomasz DziudaTomasz Dziuda
    Moderator

    You can also try to set “Remote path” just to “/”

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #544
    nilsvb

    Thank you Tomasz, it is working with the absolute remote path

    #598
    itips3727

    Thanks to @Tomasz and @nilsvb.

    Setting the “Remote path” to an absolute path worked for me too.

    Though I needed to also set the port to the correct port number specified by my web host, rather than use the default 22.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.