Sign in

Related posts in Simple

  • This topic has 4 replies, 2 voices, and was last updated 1 week, 2 days ago by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #4550
    Antonio

    Hi, to all!
    I use Simple theme, and I have two sites with the same settings for “Theme” and for “Site settings” (only texts and images are different), but in one of these don’t make related posts in preview.
    I can’t see “You should also read:” and the posts under.
    At the end of every post there are only Previous/Next buttons and footer.

    Here are my settings:
    Theme -> Custom settings -> Layout -> Post page -> Related post: 3
    Theme -> Custom settings -> Post options -> Display related posts: Enabled
    Site settings -> Post Listing -> Related posts selection mechanism: Use titles and tags
    Site settings -> Post Listing -> Related posts ordering: By ID descending
    Site settings -> Post Listing -> Related posts options: Enabled

    I’ve tried also to reset theme settings, but nothing has changed.
    In this site I used Block editor for all the posts.

    Hope you can help me.
    Many thanks in advance.

    #4551
    Bob
    Support

    only texts and images are different

    The titles are the same?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4552
    Antonio

    No, site title, posts titles, texts and images are different.

    #4553
    Bob
    Support

    The related posts are created based on Post Titles and Tags (by following your setting).
    If the titles do not contain common words, and the tags are different then the related posts are not created.

    There may be several other reasons as well: draft, hidden posts.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4554
    Antonio

    Many thanks Bob for your help.
    You understood perfectly what my problem was.

    I made a mistake, I did not understand how related posts worked.
    In the first site the posts titles were similar, made for a test and it also worked without the tags.

    I have created one tag, I have added this to some posts and I have changed:
    Site settings -> Post Listing -> Related posts selection mechanism: Use only tags

    Now all works well.

    Thank you so much for your quick support.
    Publii is wonderful.

    Good day.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The topic ‘Related posts in Simple’ is closed to new replies.