Sign in

Publii v.0.36.1 can’t handle tag for javascript and ld+json schema.org

  • This topic has 4 replies, 2 voices, and was last updated 1 month ago by .
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3183
    ClsCls

    Hello,

    I installed the new Publii v.0.36.1 (build 13320) beta. After editing my document, that had ld+json and javascript tags, it is not rendered anymore.

    I had to remove the tags and edit the html file on my server to add the tags again.

    Best, Claas

    #3187
    ClsCls
    This reply has been set as private.
    #3205
    Tomasz DziudaTomasz Dziuda
    Moderator

    Hi,

    TinyMCE is removing script tags by default. You can consider changing TinyMCE settings. I suppose that it is a similar problem: https://github.com/GetPublii/Publii/issues/674

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #3213
    ClsCls

    Hi,

    thanks for your answer.

    I added to tinymce.override.json
    {
    "extended_valid_elements": "*[*]"
    }

    But thats does not solve the problem for me.

    I also noticed that the CDATA part was added by Publii. It would be correct without the CDATA part.

    #3214
    ClsCls

    Disabeling script at all worked for me by adding:

    {
      valid_elements : "script"
    }

     

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.