Sign in

Publii 0.36 Prerelease 5!

Viewing 38 posts - 1 through 38 (of 38 total)
  • Author
    Posts
  • #2212
    BobBob
    Support

    The fifth prerelease version of Publii is ready to download for our users and testers. This time we added a few
    interesting new options and focused on fixing the user-reported bugs from the four previous prerelease versions.

    Let see what’s new:

    1. Enable Responsive Images – now you can choose if you want to deliver different sized images at
      different screen resolutions depending on breakpoints defined through config.json or serve the original RAW
      images (requires a new image markup in your theme). If you are interested in how the images work in Publii now,
      I recommend reading this guide.
    2. Enable Lazy Load – now, instead of using the external scripts like lazysizes.js to lazy loads
      images, videos, and iframes, you can use the native browser lazy loading mechanism (requires a new image markup
      in your theme)
    3. Save & Preview – now you can choose whether you want to quickly preview the front page or
      the entire site.
    4. Rendering process – the rendering process has been optimized, now all files are copied to the
      preview folder only the first time, and then only those that have been changed or new once. It’s very helpful
      for a website with a large number of images or other files.

    The full list of all changes/commits can be found on Publii Github repository

    Read more about the 0.36 Prerelease 1, Prerelease 2, Prerelease 3, Prerelease 4 version.

    There are a few important things we’d like you to know:

    1. The Enable Responsive Images, Enable Lazy Load and The Block Editor included in this release
      are only supported by the theme listed below.
    2. While technically this release works like any previous Publii release, we strongly recommend
      that it is not used to build any live projects. For testing purposes, we suggest creating a new
      test website using the listed below themes only.
    3. Posts written in the Block or Markdown Editor in this release are only compatible with
      the current version of Publii
      ; creating a post in the prerelease version and then rolling back to
      the current beta version, 3.5.x, will cause the post to crash and become uneditable.

    If you want to help us with testing the Publii Prerelease 5, you may download it right now:

    1. macOS – Publii-0.36.0-prerelease-5.dmg
    2. Windows – Publii-0.36.0-prerelease-5.exe
    3. Linux – Publii-0.36.0-prerelease-5.deb, Publii-0.36.0-prerelease-5.rpm, Publii-0.36.0-prerelease-5.AppImage

    New Blank Theme for devs

    For users that want an easy way to get started with building a Publii theme, we created a completely new Blank theme;
    you can download it by visiting the Github repo

    Simple (included in Publii package)

    1. Added support for „Enable Responsive Images” option
    2. Added support for native Lazy Loading
    3. Typo adjustment
    4. Updated Photoswipe gallery to 4.1.3 version
    5. Fixed gallery UI buttons behavior on hover
    6. Rewritten to use CSS variables

    Square square_2.0.0.0.zip.zip

    1. Rewritten (e.g. CSS variable) and a little redesigned
    2. Added support for Block editor
    3. Added support for „Enable Responsive Images” option
    4. Added support for native Lazy Loading
    5. Updated Photoswipe gallery to 4.1.3 version
    6. Removed jQuery – now uses only a vanilla js
    7. Fixed of Off-Canvas menu
    8. Added more layout options
    9. Added more font options

    Taste taste_2.0.0.0zip

    1. Completely redesigned and rewritten (e.g. CSS variable)
    2. Overhauled menu system! New scripts, two mobile menu styles (Sidebar and overlay), and a reactive submenu that
      shifts position when it gets too close to the edge of the browser window.
    3. Added support for Block editor
    4. Added support for „Enable Responsive Images” option
    5. Added support for native Lazy Loading
    6. Added more font options
    7. Updated Photoswipe gallery to 4.1.3 version
    8. Removed jQuery – now uses only a vanilla js

    Mercury mercury_2.0.0.0.zip

    1. Rewritten (e.g. CSS variable) and a little redesigned
    2. Overhauled menu system! New scripts, two mobile menu styles (Sidebar and overlay), and a reactive submenu that
      shifts position when it gets too close to the edge of the browser window.
    3. Added support for Block editor
    4. Added support for „Enable Responsive Images” option
    5. Added support for native Lazy Loading
    6. Updated Photoswipe gallery to 4.1.3 version
    7. Removed jQuery – now uses only a vanilla js
    8. Added more font options

    Tattoo tattoo_2.2.0.0.zip

    1. Rewritten (e.g. CSS variable) and a little redesigned
    2. Overhauled menu system! New scripts, two mobile menu styles (Sidebar and overlay), and a reactive submenu that
      shifts position when it gets too close to the edge of the browser window.
    3. Added support for Block editor
    4. Added support for „Enable Responsive Images” option
    5. Added support for native Lazy Loading
    6. Updated Photoswipe gallery to 4.1.3 version
    7. Removed jQuery – now uses only a vanilla js
    8. Added more font options
    9. Fixed skipping page when the sticky menu appears

    Technews technews_2.1.0.0.zip

    1. A little rewritten (e.g. CSS variable)
    2. Added support for Block editor
    3. Added support for „Enable Responsive Images” option
    4. Added support for native Lazy Loading
    5. Updated Photoswipe gallery to 4.1.3 version

    QF qf_2.0.0.0.zip

    1. A little rewritten (e.g. CSS variable)
    2. Added support for Block editor
    3. Added support for „Enable Responsive Images” option
    4. Added support for native Lazy Loading
    5. Overhauled menu system! New scripts, two mobile menu styles (Sidebar and overlay), and a reactive submenu that shifts position when it gets too close to the edge of the browser window.
    6. Added more font options
    7. Removed jQuery – now uses only a vanilla js
    8. Updated Photoswipe gallery to 4.1.3 version

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2225
    Yoav

    Bravo!

    #2226
    Verhoeckx

    Ah this is great! I will test the prerelease the coming days.

     

    Two questions:

    1. Which of the fonts available in the new Taste resembles the original font, Nunito, the most? Why is the original font removed?
      The original font of the title (Damion) is also removed?
    2. Am I correct and is the layout of the new Taste theme changed? The title and menu of the website site are now next to each other?
      I think I have to restore this manually?

     

     

     

    #2227
    BobBob
    Support

    Two questions:

    As you can read in the changelog, the Taste theme has been completely redesigned and rewritten. It is a free theme created by me and I did not like its old look. Don’t forget that you can still use the old one.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2228
    Verhoeckx

    Hello Bob,

    Yes,  I read the change log but still I didn’t expect a completely different layout.

    Sorry, I just feel a little bit grumpy because I spend the last two days adjusting the theme and now I have to do that all over again. And have to restore the site to its original layout. I want to use the new theme because other aspects are indeed better.

    Do you happen to know which font looks the most to the original font?

    Verhoeckx

     

    #2230
    BobBob
    Support

    Unfortunately not; you should check one by one and see how they look.
    Alternatively, open the partials/fonts.hbs file and edit one of the “records” by changing the font family to https://fonts.googleapis.com/css?family=Nunito:300,600%7CMontserrat%7CDamion (it comes from the old theme version)

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2232
    noapmtl

    I got an error when site syncing  :

    Rendering process failed
    An error occurred during rendering process:

    ENOENT: no such file or directory, scandir ‘/Users/nicolas/Documents/Publii/sites/nicks-blog/output/media/posts’

    I can see that I have a “files” and “website” repertory in the media folder,

    Any idea what I’m doing wrong ? – Thanks

    #2233
    noapmtl

    When I retried syncing, I got another error message :

    “An error occurred during connecting to the server. Please check your server settings or try again.” Server is on Netlify, fresh install, first syncing.

    Thanks

    #2234
    noapmtl

    Sorry for the multiple posts, I progressed in my debugging and found out from the log that it’s an ID issue

    – – Netlify ERROR – –
    TypeError: Cannot read property ‘id’ of undefined
    at NetlifyAPI.deploy (/Applications/Publii.app/Contents/Resources/app.asar/back-end/modules/deploy/libraries/netlify-api.js:28:40)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    – – – – – – – – – – –

    When I checked the ID, it somehow changed to the name of the blog. I insert back the API ID, however I still have the same error message.

    A test connection doesn’t work anymore, however it worked when I add the Netlify settings after my fresh install.

    #2235
    noapmtl

    Sorry for the multiple posts, I progressed in my debugging and found out from the log that it’s an ID issue

    – – Netlify ERROR – –

    TypeError: Cannot read property ‘id’ of undefined

    at NetlifyAPI.deploy (/Applications/Publii.app/Contents/Resources/app.asar/back-end/modules/deploy/libraries/netlify-api.js:28:40)

    at processTicksAndRejections (internal/process/task_queues.js:93:5)

    – – – – – – – – – – –

    When I checked the ID, it somehow changed to the name of the blog. I insert back the API ID, however I still have the same error message.

    A test connection doesn’t work anymore, however it worked when I add the Netlify settings after my fresh install.

    Last post regarding this issue 🙂  I don’t know why, but Publii created multiple record in Keychain on mac with wrong ID information. I’ve deleted all the record in keychain, entered the proper ID in Publii, and now it works like a charm 🙂

    #2237
    noapmtl

    last last update… ID keep resetting, with following information :

    Site ID : publii-netlify-id name-blog
    Netlify token : publii-netlify-token name-blog

    with name being the publii blog’s name

    #2248
    Alex

    When you push the button to create new post, can you focus type cursor immediately to be able to write?

    Now i need to click new post, then click t tittle to start writing

     

    Thank you

    #2249
    Alex

    I see some theme has been updated. Bob, please can you check if ProDocs theme can be updated to change/fix that Info, Hightlight, Success and Warning styles can include Bullet and Numbered lists

    Thank you

    #2251
    BobBob
    Support

    Bob, please can you check if ProDocs theme can be updated to change/fix that Info, Hightlight, Success and Warning styles can include Bullet and Numbered lists

    These typo elements work very well in the ProDosc Theme, I don’t understand why you are writing about this in this thread.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2253
    Verhoeckx

    Hello Bob,

    Sorry for my reaction last week. I was a little bit annoyed that I had to restore the design of the website. But you are right: I get you theme for free so I shouldn’t complain! I have to use the new version of the theme because I want the block-editor to be supported.

    I haven’t thoroughly reviewed prerelease 5 but there are already some bug that I can report.

     

    General bugs

    1. As mentioned above, in another post, the password of the connection still ‘resets’ itself.
    2. When using the WYSIWYG-editor: the text popover disappears before I can click on an item.
    3. When using the Block-editor: after adding an e-mail address to a link (Link -> External), https is added to the link.

     

    UI bugs

    • Have you decided how to show HTML code in the block-editor? Right now the code is interpreted and this means you get to see form elements when you have added them. This looks strange and makes the block-editor look unreliable. My suggestion: show the code or show an image on top of the HTML code (with the same height as the beneath it).

     

    Feature request

    • Can you check how many databases connection are open at a given moment? If so, could you add a warning that someone else has already opened a website (and thus is editing the website)? This in order to prevent a database conflict. The reason I’m saying this, is that I already noticed a few times a database conflict on the file db.sqlite in Dropbox. This despite the fact that I and the other person try not to edited the website at the same time. I know this problem is fundamental to the architecture of Publli. Having said that: I think this problem needs to be solved somehow.

     

    Taste theme bug

    • The line {{> top}} in the file index.hbs needs to be removed because this partial doesn’t exist anymore.

     

    Thanks for Publii and good luck with the development!

    Stay healthy,

    Verhoeckx

    #2254
    BobBob
    Support

    @ Verhoeckx Thanks for your comments. Are you sure the {{> top}} exists in the Taste theme? If that were the case, you wouldn’t be able to render the page.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2255
    Verhoeckx

    Hi Bob,

    You are correct, I did get an error:

    Rendering process failed
    An error (1002) occurred during parsing index.hbs file.
    The partial top could not be found

    I wanted to keep my feedback efficient and that’s why I didn’t mention it :-).

    Verhoeckx

    #2256
    BobBob
    Support

    I’ve checked it and it works as should, so I suppose you are using the overridden index.hbs file.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2257
    Verhoeckx

    Sorry, you are right: the line isn’t there in the official theme! Oeps!

    #2258
    BobBob
    Support

    😈

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2259
    Alex

    is it just me or? wheel scrolling doesnt work in HTML editor?

    #2260
    BobBob
    Support

    is it just me or? wheel scrolling doesnt work in HTML editor?

    It works.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2261
    Alex

    sometimes it gets stuck or like this

    Attachments:
    #2263
    BobBob
    Support

    Ah, ok, you are talking about the Source code editor.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2264
    Alex

    it would be also nice to have the ability to leave HTML be formated as i manually edited. Once i press Save, all my tabs/spaces are gone.

    Or can i use external editor (im on mac)?

    #2267
    Alex

    Also, looks like HTML editor (not Source Code) getting slower (mac) when you have a looong post to be edited

    #2284
    Verhoeckx

    Hello Bob,

    Do you have a screenshot of the homepage of the new Taste theme?
    It’s makes it a little bit easier for me to adjust the theme.

    Verhoeckx

     

    #2286
    Verhoeckx

    Small bug
    In the Block-editor: when you press on the update icon at the top of Table of contents, the title is restored to ‘Table of contents’. It should keep the name that the user manually entered.

     

    Comment
    I see it’s now possible to add a link to an image in the Block-editor. That’s great 🙂 !!

     

    Thanks for terrific work!

    #2298
    Theo

    First of all I want to say that Publii 0.36 is a major leap forward.

    I do have a question regarding spell checking: It looks to work with the Windows user interface/desktop language. In my case it’s Dutch. This makes spell checking in English difficult. Is there a setting I should change to switch to English spell checking or is this a current limitation of the system?

    #2299
    BobBob
    Support

    I do have a question regarding spell checking

    All you have to do is change the language of your website: Site Settings -> Basic Settings -> Language

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2300
    Theo

    I do have a question regarding spell checking

    All you have to do is change the language of your website: Site Settings -> Basic Settings -> Language

    Hello Bob,

    I tried that setting. If I switch to English (International) or English (USA), it doesn’t appear to have any effect. Additional info: I’m testing using Windows 7.

    Attachments:
    #2302
    BobBob
    Support

    it should work, please restart the app and see what happen.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2305
    Theo

    it should work, please restart the app and see what happen.

    Sorry Bob, still no luck.

    #2306
    BobBob
    Support

    Ok, probably this is a bug.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #2308
    Verhoeckx

    More Dutch Publii users, yeah 🙂 !!

    Next week I will try if the Dutch spell checking works correctly on my system.

    #2319
    Verhoeckx

    Earlier I wrote:
    “When using the Block-editor: after adding an e-mail address to a link (Link -> External), https is added to the link.”

    That’s completely correct:
    What happens is that the at sign and the text before the at sign is removed and that the protocol https:// is added. Or in another way: the e-mail address points to the address of the website.

    #2325
    Verhoeckx

    Small bug

    When you press the backspace in a popup window in the Block-editor the cursor goes to the previous (above) text field instead of deleting the previous character (the character at the left side of the cursor).

     

    #2328
    Verhoeckx

    Possible bug

    I’m not sure if this is a bug or not but when I mark a post as ‘featured’ and mark it as ‘Exclude from homepage’ it still shown on the homepage. I’m not sure what the rules are, should be.

     

Viewing 38 posts - 1 through 38 (of 38 total)
  • You must be logged in to reply to this topic.