Sign in

Publi does not update startpage pages

  • This topic has 9 replies, 2 voices, and was last updated 1 week, 6 days ago by .
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #4504
    Cls

    Hello,

    Publi does upload my startpage to the server, but the changes are not visible in the webbrowser. (It is not a cache problem.)

    For the start page I had to copy the file /page/6/index.html manually to the root folder to make the changes visible.

    Also the same page is visible under /, “index.html” and “/page/6/index.html” what can be a duplicate content problem.

    In the sitemap you can see, that there are zero images counted, although there are many images on the startpage.

    I am using the latest version of publii.

    Do you have any idea what is the problem here?

    #4505
    Cls

    I recognized also that the latest image that I uploaded on the startpage is located at /media/posts/1/…

    Is there maybe something mixed up?

    #4506
    Cls

    And also in the source code are references for rel-next and rel-prev to /page/6/ and /page/5/. A SEO audit also discovered that there are references to /page/3/ and other aliases for the startpage.

    #4507
    Bob
    Support

    What are you talking about?  Any URL, site backup?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4508
    Cls
    This reply has been set as private.
    #4509
    Bob
    Support

    I regagnized this problem because publi is not updating my startpage automaticly.

    It’s not a Pubii problem, check your cache, maybe you are using something like cloudflare.com, I don’t know. But I’m sure the problem is not with the app.

    In terms of the pagination issue – you are displaying the selected post on the homepage, so in Theme Settings – Basic settings – set 0 or 1 value in the “Post per page” filed. It should help.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4510
    Cls

    Why do you think this is a cache problem? From my perspective it is definitly not possbile that this is a cache problem.

    I don’t use cloudflare. It is a simple managed webhosting.

    Have you checked all the aliases? The startpage should not be visible under different urls.

     

    #4511
    Bob
    Support

    Why do you think this is a cache problem. From my perspective it is definitly not possbile that this is a cache problem.

    Because I work with Publii every day and I have no problems with that, as well as many other people.

    Have you checked all the aliases? The startpage should not be visible under different urls

    Set 0 value for the“Post per page” field under the Theme Settings – Basic settings.  Also, go to the Site Settings – SEO – and in the Frontpage section,  disable homepage pagination indexing.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4512
    Cls

    Homepage pagination was already disabled. I enabled it and disabled it again.

    Nevertheless, that worked!

    Thank you!

    #4513
    Bob
    Support

    Good to hear that.

    Thank you for your donation, I really appreciate that.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Publi does not update startpage pages’ is closed to new replies.