Sign in

Pretty URL/.httacess changes

  • This topic has 1 reply, 2 voices, and was last updated 1 month ago by .
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3229
    t.martin

    Hello Publii team!

     

    Working on a new site in Publii I have encountered a small issue with the posts and pretty URL option. I am using individual posts as “pages” on the site, with links directly to them i.e.: LINK <a/>

    When turning on the option for pretty URL to remove .html suffix I get error when the pages refuse to load. I have customised the default post template provided by the theme, but am struggling to figure out what the Tag prefix would be. I read several forum posts on this, but all the answers are regarding using the menu item/hidden posts. I am not certain this would help my case, as the navigation sidebar is also fully custom build from the ground up with links to the individual posts.

     

    I know how to remove the .html affix inside .htaccess file, but cannot seem to locate it. Any idea where it would be (we are hosting via AWS S3)

    Hoping you can kick me in the right direction! 🙂

    Warmest regards

    #3230
    BobBob
    Support

    I really don’t understand why you try to remove the .HTML suffix by htccacess. The pretty URLs work very well; could you provide me the site URL where the problem exists?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.