Sign in

NoIndex Images URL

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #910
    b0ttr

    What’s the easiest way to disable indexing of Media and Assets folders in Publii?

    All images and assets URLs are indexed by Google which is not ideal.

    #916
    BobBob
    Support

    Hi,

    I think you can try to use robots.txt with the following rules:

    Block one folder
    `User-agent: *
    Disallow: /folder/
    `
    Block one file
    `User-agent: *
    Disallow: /file.html
    `
    More detailed information you can find here: https://moz.com/learn/seo/robotstxt

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #917
    b0ttr

    Robots.txt only works after you’ve NoIndexed existing image URLs. Otherwise Googlebot will never be able to reach those URLs in the first place.

    If there’s no direct/simple way to achieve this, another way of addressing my concern would be – how to ensure Publii doesn’t generate dedicated pages/URLs for Images? This has been a major issue with Yoast SEO on WordPress sites in the past.

    #918
    BobBob
    Support

    What do you mean by dedicated pages/URLs for Images?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #919
    b0ttr

    So I see links like `https://example.com/media/posts/2/abc.jpg` generated from my posts where I’ve uploaded pics.

    #920
    BobBob
    Support

    Yes, this is normal behavior; images must be located somewhere, and if you want to display them on a web page linked from that location.
    To remove the full src path, you can try to use Relative URLs in server settings, but I’m not sure if it helps.

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #921
    b0ttr

    Is there no way to add NoIndex tag on images URL?

    #922
    BobBob
    Support

    There is no Noindex tag for an image element, instead, try to use X-Robots-Tag https://developers.google.com/search/reference/robots_meta_tag

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.