Sign in

Bug fix for Massively Theme

  • This topic has 6 replies, 2 voices, and was last updated 1 week, 5 days ago by .
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4514
    amdijefri

    Like the person in this post, I was trying to edit the hero text in the Massively theme. The suggested solution is not correct, so I dug around and discovered a bug in Massively’s config.json. I have tried repeatedly to post a diff, but WordFence keeps rejecting my post, so here is a step-by-step how-to. I hope the fix makes its way into a future release.

    File: massively/config.json, version 1.1.1.0

    1. Delete lines 132-142 that specify a separator (possibly optional, but it keeps the GUI consistent)
    2. Delete the p tags in line 147; none of the other note fields in the json file use HTML tags.
    3. Change value from default to post.

    Site maintainers: please fix your WordFence configuration so that code blocks, or URLs, or whatever it was that I was running afoul of, can be submitted.

    #4517
    Bob
    Support

    What is in your opinion a bug here? You can edit the hero’s text via the theme settings, so where’s the bug?

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4518
    amdijefri

    Except I could not edit the hero text in the theme settings until I applied the fix I described above. Here it is with the theme as downloaded:

    Attachments:
    #4520
    amdijefri

    And here it is with the modified theme:

    Attachments:
    #4522
    amdijefri

    I was having the same problem as described in https://getpublii.com/forum/topic/how-to-remove-default-text-in-massively-theme/#post-3985 until I modified the config.json

    #4524
    Bob
    Support

    Ok, I got it, the intro text field is missing when the “Selected post” is selected in the Front page section.
    Fixed in the 1.1.2.0 theme version https://marketplace.getpublii.com/product/massively/

     

    --
    Do you appreciate the support you've received today? If so, consider donating to the Publii team by clicking here; we'll be sure to use your donation to make Publii even better!

    #4525
    amdijefri

    Ah, so the Intro Text field was only appearing when the Front Page Displays was set to Latest Posts? Front Page Displays was one of the first things I changed; I guess that’s why I never stumbled upon the distinction. Thanks for updating the theme!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Bug fix for Massively Theme’ is closed to new replies.